Funciones condicionales en Excel

Conoce las funciones SI a forma de condición

SUMARSI.JPG
Imprimir pantalla Microsoft Excel Cuesta Y.

El programa de hojas de cálculo Excel  tiene una gran cantidad de fórmulas y funciones, en este artículo en concreto vas a conocer las funciones condicionales del mismo, que se encuadran en las funciones lógicas del programa.

Estas funciones se caracterizan por que contienen una condición a través de la cual según se cumpla o deje de cumplirse establecerás la obtención de un resultado.

Como es más fácil hacerlo que decirlo vamos a ver ejemplos prácticos de diferentes funciones condicionales en Excel.

En concreto:

  • Función SI
  • Función SUMAR.SI
  • Función SUMAR SI CONJUNTO

Para otras funciones lógicas ver: Aprende en profundidad las funciones lógicas.

Empecemos:

  • Función SI

Esta es la sintaxis general de la función:

=SI(condición lógica; “Valor verdadero”; “Valor falso”)

Piensa en el siguiente ejemplo: Tienes una hoja electrónica donde se reflejan las notas de unos alumnos, en donde quieres saber si el resultado de cada alumno es aprobado o suspenso.

Con la función lógica SI, puedes escribir una fórmula en la que indiques los siguiente: si la nota es menor de 5 te devuelva el valor Suspenso, y en caso contrario Aprobado.

La función que necesitas es:

=SI(A6< 5;" Suspenso ";" Aprobado ")

Ver imagen SUMAR.SI ampliada.

 

  • Función SUMAR.SI

Entes caso la sintaxis es:

SUMAR.SI(rango;criterio;rango_suma)

Escribe en una hoja de cálculo Excel en blanco los siguientes datos: En la columna A tienes los nombres de una serie de personas: Rosa, Juan, Rosa, Paco, Juan y Rosa.

En la columna B las cantidades que por ejemplo han aportado a las fiestas del colegio: 5, 4, 6, 3, 5, 1.

A                       B

Rosa                  5

Juan                   4       

Rosa                  6

Paco                  3

Juan                   5

Rosa                  1

Varias personas han realizado aportaciones más de una vez, para saber cuánto ha aportado Rosa, tienes que usar la siguiente fórmula:

=SUMAR.SI(A1:A6;A1;B1:B6)

En total Rosa ha aportado 12 dólares.

¿Puedes calcular con la función SUMAR.SI cuanto ha aportado Juan?

Solución: 9 dólares

 

  • Función SUMAR SI CONJUNTO

En este caso vas a suponer que tienes una hoja de cálculo Excel en donde en la columna A esta la lista de los vendedores de una tienda de electrodomésticos, en la columna B la lista de productos vendidos y en la columna C el importe de cada venta.

Y quieres conocer el importe acumulado vendido de un determinado artículo de un   vendedor en particular.

En concreto quieres saber el importe que ha vendido Rosa en Secadores.

A                       B                           C

Rosa            Secador                      50

Juan             Plancha                      40      

Rosa            Secador                      50

Paco            Cafetera                      30

Juan             Exprimidor                  10

Rosa            Plancha                      40

Pues bien para conocer el importe en dólares de secadores que ha vendido Rosa empleas la función SUMAR.SI.CONJUNTO de la siguiente manera:

 =SUMAR.SI.CONJUNTO(C2:C7;A2:A7;A2;B2:B7;B2)

Ver imagen SUMAR.SI.CONJUNTO ampliada.

Tip: Estos ejemplos son sencillos para aprender, por ello el número de datos no es elevado, pero imagina la de trabajo que ahorras con extensas hojas de cálculo llenas de datos.

Si quieres comentarme al respecto de este artículo o cualquier otro del site hojas de cálculo About.com, puedes contactar por email o a través de las redes sociales, FACEBOOK - TWITTERLINKEDIN