Aprende en profundidad las funciones lógicas

Camara Excel Cuesta Y.

Funciones lógicas

Las categorías de funciones que existen en Excel son varias: Matemáticas, Estadísticas, base de datos, texto,… y entre ellas se encuentra la categoría denominada funciones lógicas.

Como puedes leer en Descubre las funciones de información y las funciones lógicas dichas funciones lógicas son: Y, FALSO, SI, SI.ERROR, NO, O, VERDADERO.

En ese mismo artículo puedes practicar un ejemplo sencillo de la función lógica SI.

Ahora vas a conocer otros ejemplos sencillos con otras de las funciones de esta categoría.

Función Y

Con esta función obtendrás el valor verdadero, si todos los argumentos se cumplen, en caso contrario obtendrás falso. Se usa conjuntamente con la función lógica SI.

Ejemplo:

Tenemos las notas de dos trimestres del primer semestre del curso y para pasar al siguiente el alumno tiene que sacar en ambos trimestres una nota superior a cinco. Solo lo cumple la alumna Rosa porque es la única que ha sacado unas notas superiores a cinco en ambos trimestres.

Introduce los datos de la imagen,ver imagen ampliada, y en D2 escribe la fórmula y hasta D5 rellena con el controlador de relleno:

Función Y como primer argumento de la función SI:

=SI(Y(B2>5;C2>5);"Pasa de semestre";"Repite")

Obtendrás los siguientes resultados:

Repite

Pasa de semestre

Repite

Repite

Función O

Con esta función obtendrás el valor verdadero, si alguno (no todos, basta con que uno se cumpla) es verdadero.

Se usa conjuntamente con la función lógica SI.

Si todos los argumentos de la función O descrita son Falsos la función devolverá el valor falso.

Ejemplo:

Tenemos el mismo ejemplo que antes de las notas de dos trimestres del primer semestre del curso. Ahora para pasar al siguiente semestre basta con que el alumno saque en uno de los trimestres una nota superior a cinco.

En este caso el único que no lo cumple es el alumno Juan porque es el único que ha sacado unas notas no superiores a cinco en alguno de los trimestres.

=SI(O(B2>5;C2>5);"Pasa de semestre";"Repite")

Obtendrás los siguientes resultados:

Repite

Pasa de semestre

Pasa de semestre

Pasa de semestre

Función NO

Se aplica sobre una condición para devolver el valor contrario o opuesto al de la condición. No es muy frecuente su uso.

Esto es: devuelve VERDADERO si la condición en falsa y obtenemos FALSO si la condición es verdadera.

Sintaxis de esta función:

NO(valor_lógico)

Donde Valor_lógico es un valor o expresión que puede evaluarse como VERDADERO o FALSO.

Ejemplo:

Escribe en la columna B tres veces el número 5 y en C tres veces el número 10. Las filas que se usan en el ejemplo son la 9, 10 y 11.

Esta es la formula NO empleada en cada uno de los casos:

=NO(B9=C9)

=NO(B10>C10)

=NO(B11

Y los resultados que se obtienen son:

Verdadero

Verdadero

Falso

Función SUMAR.SI

Esta función, no pertenece estrictamente a las funciones lógicas pero sí está relacionada con ellas.

SUMAR.SI, lo que hace es la suma de las celdas en el rango que coinciden con el argumento criterio.

Sintaxis:

SUMAR.SI(rango;criterio;rango_suma).

Rango es el rango de celdas que desea evaluar.

Criterio es el criterio en forma de número, expresión o texto, que determina las celdas que se van a sumar. Por ejemplo, los criterios pueden expresarse como números, condiciones, texto.

Rango_suma son las celdas que se van a sumar.

Ejemplo:

Introduce los últimos datos como aparecen en la imagen, en este caso se han introducido desde las celdas B13 a C17. Se trata de hallar la suma de las ventas de Mario.

=SUMAR.SI(B14:B17;B14;C14:C17), donde en los argumentos de la función SUMAR:SI lo que se está pidiendo es que en el rango de celdas donde están los nombres de los vendedores, cuando aparezca el vendedor Mario, me sumas las ventas que este ha realizado.

Resultado: 105, que es la suma de las ventas de Mario.